9 posts / 0 new
Last post
OmnibotMan's picture

I have recived a tomy verbot to my omnibot collection, he's got a few problems. One, the antenna is missing along with the remote controll. Someone chopped off the reciver antenna. he is really dirty, but I cleaned him off some. His batteries are corroded, but I cleaned them some too. If you own a verbot, you may know that they move pretty slow, but I should replace some motors in it with either servos or new motors. And, its CHOCKED FULL of gears. Thats why its soo noisy!!  I am gonna make a how to video of how to replace a verbot's antenna, and how to hack a walkie talkie to function as a remote for he verbot. My youtube account is called BillyMouth, lol. I dont like the singing fish anymore, but I do have 4 really cool ones and I do repair them too and mod them too. But post here if you have omnibot or tomy related issues, because I am an expert at tomy robotic products like the omnibot (verbot, omni jr, robie sr, ect..)

EvanS.'s picture

I just bought a Verbot from Craigslist today. It won't accept any commands. The main reason for this is because the antenna is snapped off near the base of the Verbot.

EvanS.'s picture

I also have a Robie the Robotic Banker from radioshack, the same one you have in ur YouTube video. Unfortunately, mine doesn't work. Lastly, I also have that tekno dog and poochi in my basement or somewhere, they both work but I don't care about them. All I want is for my Verbot and Robie the Robotic Banker to get fixed and work.

MDC's picture

Hy !

I am a proud owner of a Verbot ,but it also doesnt work well.
After the Robot is programmed (the red light goes from "flashing" mode in "on" mode)
he doesnt give any reaktion after speaking any commands.
Do you have any idea whats wrong with it?

Thank You

Markus from Austria

nomad's picture

hi all,you can start whit electronic cleans all electronics inside.
also connectors .spray them in and let it good dry and test what you got then.

Shaun's picture

For the antennae, maybe you can just unbend a paper-clip and shove it into a socket. I've tried it before, and it works.

Zorua635's picture

I got a verbot from a flemarket for $5 his case was corroded but I gave him a new 4AA battery case he lights up but with the 2Cs he wont do anything can u fix it for me plz

Qasim's picture

Maybe you can just unbend a paper-clip and shove it into a socket. I've tried it before.....

RobFromLI's picture

Have my verbot from when I was a kid... in the box w/manual n everything. Problem is same as someone listed above - he will let me program him (light goes steady) but he won't do anything when I give commands. Is it possible the motor / gears are stuck and opening him and giving them a gentle nudge would free him up? Anyone successfully repaired one?