Software Usage

24 posts / 0 new
Last post
VK
VK's picture
Software Usage

Hi there, Wanting to know how to use the macro function in the media suite. The manual does not say specifically how to use it.

england_pete_73
england_pete_73's picture

It's really confusing! Arrgghhh!

VK
VK's picture

Hi there, I have created a simple macro whereby when the right foot front button is pressed RS "burps" then laughs and if not then is will lie / sit down. Very simple, I have added this macro to my own personality (which is a copy of the default) as well as to one of the other default personalities.

I have added it to the "user body con 1 " area which is triggered by LR plus select key. I have dowloaded this macro using the media suite provided and if I browse the personality and the macro folders via the PC I see my macro in the user body con folder, which is good news as the file has been tranferred to RS.

When I try to run the macro, triggering it by pressing the LR plus select button as well as pressing the (right foot buttton) nothing happens. My macro does not run. Remember that the "burp", laugh is all located in the RS2 folder when you are adding a "action" using the macro editor. Could this be the reason, does anyone have any similar problems, is my bot broken? am I doing something fundamentally wrong?

Please HELP, I have been playing around for days Cry with no joy

 

Nocturnal
Nocturnal's picture

Could you post a copy of the macro so I can have a look?

VK
VK's picture

How do I post it, tried to copy and paste no joy. I do not have a website, I can send it to your private email address?

Nocturnal
Nocturnal's picture

The file is plain text (so you should be able to open it up in notepad and cut and paste the text). If you can't get that to work, just send it to me in an email or pm.

VK
VK's picture

#number of Bcons: 1
#C:\Personal\RS Media\Test.bcn
#Start Macro|StartEvent|1|
#If The Right Foot Front Button Is Pressed|Condition|2|yesno|$(RSM_FOOT_R_F) -eq "1" |\Images\conditionals\right-foot-front.gif
#RS2 Insult|Action|1|/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x36D 0x00 
#RS2 Laugh|Action|1|/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x36C 0x00 
#RS2 Hug|Action|1|/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x379 0x00 
#End of Macro|EndEvent|0|
#Lie Down/ Sit Up|Action|1|/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x351 0x00 
#End of Marco|EndEvent|0|
#code section:
#!bash
PATH=/usr/bin/robot/state:/usr/bin/robot/script:$PATH

if [ $(RSM_FOOT_R_F) -eq "1" ];
then
/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x36D 0x00 
/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x36C 0x00 
/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x379 0x00 
else
/usr/bin/robot/send_robot_cmd 0xff 0x05 0x01  0x351 0x00 
fi

Nocturnal
Nocturnal's picture

That script doesn't work for me, nor does the test one I created
along a similar vein. It also doesn't work calling a bodycon script
(though the bodycon script works when called directly). I tried calling
it through a personality as well as directly from the command line.
When I first started exploring the Media, I had a theory that those
actions actually sent an IR command to a RS V2, but I discarded that
idea shortly afterwards, maybe I should test it.

 Also, for
some reason, the script you provided did not work (for me) detecting
the button press, though the one I created did.

 Something
else of interest, the last thing the bodycon does is call
/usr/bin/robot/scripts/wait_media.sh, but that script doesn't exist.

VK
VK's picture

Nocturnal, I also tried to use only the RS Media actions and still my macros do not work.

The macro that worked for you, can you please post a copy and I will try it and then we can confirm if my bot does not need sent back to WowWee as it does not work.

I do not have a V2, could you confirm if those actions in the RSV2 folder are as you suspected, for sending commands to a V2. I was under the impression that those actions actually will be beformed by RS Media, I was very impressed because RS Media does not do some of the functions that V2 does like, burp, laugh, etc.

Nocturnal
Nocturnal's picture

My V2 has been in a persistant vegative state for quite a while now.
But I have other means of testing such things. I'll try to have a look
tonight and see what I can find.

VK
VK's picture

What about posting the macro that worked, so tonight I can check if it also works with my RS

Nocturnal
Nocturnal's picture

It only worked detecting the button press, it didn't actually succeed
in doing anything it was supposed to do other than that *Laughs*

VK
VK's picture

Hi Nocturnal,Sent an email to WowWee customer care and the technical person there confirmed that the RS2 folder actions are meant to interact with a V2, so you were on the money with you assumptions.

The IR on the head of RS is actually a Transmitter and Reciever??? or are they seperate (conversation for another topic).

I am not so happy because I paid more that double the price for RS and he does not even do some of the functions that V2 does like laugh, hug, burp etc. I expected the RS to come defualt with the V2 functions and then just add more functionality for the RS.

Anyway, can you please try and create a macro using only the RS Media actions (very few to say the least) and see if your's works. I tried creating a macro  using on the RS actions only and yes, no joy. I am beggining to think that the RS is a actually a waste of money and the V2 is much better.

Nocturnal
Nocturnal's picture

The three round LED's under the camera are IR LED's, they are mostly
used for his IR Vision, but they also transmit signals for interactions.

I'll try creating one shortly.

while you wait you might enjoy this,
http://pruim037.proboards107.com/inde...
I just added a video at the bottom, it should keep you entertained for
a few minutes.

 For some reason, half the buttons seem to be missing from the post editor, I can't add a link properly.

Khalid J Hosein
Khalid J Hosein's picture

Hey Nocturnal,

Sorry about that. We just upgraded the platform and the default editor is now a scaled back version (which may still change yet). However, you can go back to the original editor with all of the features by going to your profile and checking the "Enable Advanced Editor?" box.

PS> This is also in the Community Tips section

VK
VK's picture

Hi Nocturnal and others,

I now have an even bigger problem; my RS does not want to swap between modes i.e control, arm, and media. When I boot RS, the default system check sequence runs successfully but the splash screen still shows the default WowWee logo although it is in the Command Mode. If I press the M button on the remote or the external Arm buttons the mode switches to arm mode but does not go any further irrespective of the number of times I press the M button or the external arm buttons. This is what I did before this problem occurred:

1. I connected RS to my PC using the USB and manually browsed the personality folders and deleted all the personalities' i.e.Service Bot, Space Bot, Billy Joe. This was done to create memory space
2. I then uploaded my personality which is 41866.65 Kb to RS using the Media Suite software.
3. I then rebooted RS and the symptoms mentioned above are now present.

How do set RS to the default factory settings since I cannot get to Media Mode and therefore connect to RS via USB? I checked the battery voltage level and all seems fine, RS does not complain that the batteries are flat. I even removed the batteries and left RS for the entire night hoping that the memory would erase and the default factory settings would then be effective when I rebooted, but still no luck.

Please help as I think RS is now broken??

Nocturnal
Nocturnal's picture

What you do is get a SD card if you don't already have one (which is
where you could have put your large personality), you'll also need a SD
Card reader. Then you ask me nicely to send you the script I wrote that
will run off the SD card at boot up and format the partition (ie
erasing your personality and anything else on there).

 If that doesn't work we'll have to try something else.

VK
VK's picture

Hi Nocturnal, I have finally gave my RS back to the shop as this was the second one that gave me problem. The first one's camera was not working and now this problem. This RS is just not stable. I have made up my mind to wait until late next year when Wow Wee gets another model out that is more stable like the V2. I think this is the first attempt for Wow Wee to use external software to interface to their robots, and they have not got it too spot on in my opinion as the software forever falls over and needs rebooting and I noticed that the "processor" is not too fast when it comes to processing macros.

So I hope that the next Wow Wee robot is really out of this world and comes out soon. Thank you for all the assistance. Do you know when Wow Wee is releasing another bot?

Nocturnal
Nocturnal's picture

Sorry to hear you returned it VK. The software in the RS Media (the
linux bit) was supplied to WowWee by a company called emsoft, I'm not
overly impressed with the job they did either.

 In early
january there is a show called CES (Consumer Electronics Show), WowWee
is supposed to be there, that's where we will mostly likely first hear
about any new bots they are planning on releasing.

Michelle C
Michelle C's picture

I just wanted to address VK's observations about RS Media... As is the
case with most software based products, we are constantly improving and updating
the software and documentation... The physical problems with RS Media are not the norm though. You can always get the latest version of
the PC software by downloading it off the WowWee support website
(www.wowweesupport.com). You can also get the latest version of the instruction
manual and look through the RS Media Editing Suite help files online.

If you hit other snags with the robot or the software, there is also
an entire library of FAQs and Troubleshooting tips you can consult on the WowWee
support website. We are continually updating this content to make sure all
aspects of the robot are covered. I encourage you to have a look at the material
we've posted online for all our customers.

If your questions are not answered by the FAQ or troubleshooting topics,
we have skilled technical experts who are readily available to work through the
problems. Consumer support and satisfaction is very important to all of us at
WowWee.

blade
blade's picture

wow just reading what VK said....and i dont like the sound of that for the money i have paid out on the rs media and other bots for xmas...but still i will give it ago and see for myself how it performs.

i just wonder if we will get new personalitys to download from wowwee or are we just left to make are own ?

and will we get updates for the bot....well as i am new thats just a few things i have been thinking and may not have seen posts about them.

Nocturnal
Nocturnal's picture

Assides from the personalities on the RS Media, I beleive the we are
pretty much left to make our own, though you never know, WowWee might
release a personality ever now and then.

The RS Media is capable
of having its software updated, but there won't be an update till there
is something that needs updating. 

Billy
Billy's picture

Does anyone have experience of the Q4 Technologies beta software ?

Brisbane RS
Brisbane RS's picture

Can the default personality be changed if you have added an sd card? The sd card seems to inhibit some functions on the bot.