Are these faults or "design features" ?

13 posts / 0 new
Last post
MightyProtonB
MightyProtonB's picture
Are these faults or "design features" ?

Hi all.

I'm new to the forum, located in Perth Western Australia (timezone not available in the profile !!!  :-)   ) and became a robot owner for the first time when my wife linked my (alleged) love of gadgets to the Christmas gift buying process.

I can see that the programmability could be a lot of fun. At the moment though I haven't loaded the software because I'm thinking of returning the RSM to the store instead.

I have four issues - three real and one temporary. The temp one is that even turning the thing on freaks out my 1 1/2 yr old son. Since it's about his height it's understandable. You should try lying on the floor and have it walk towards you. When you see it from that perspective he probably has a point but he'll get over it.

The three real issues are :

1) doesn't walk in a straight line

2) when in free roam it will get stuck in a loop where for Eg it stops, says "did I hear something" pauses for a while, says "hmm strangely silent again", does a brief twitch and then goes back to "did I hear something".

It does this in different personalities just the same but with the sayings changed obviously.  Occasionally it breaks out of this. More often than not though it just goes around the loop until you get sick of it and then the problem can be solved by a STOP foloowed by resuming free roam mode. At a varying amount of time after going into free roam mode it will then drop back into this loop; always the same

3) remote controller has left and right swapped over. I'm assuming a normal operation where the front of the remote equals the front of the RSM so that the top arrow is forward, bottom arrow is backwards, left arrow on remote turns it left and right arrow turns it right. Just like a radio control unit. What I have is that left remote button turns it to the right and right button to the left. Also in arm mode I'm pretty certain (not sitting in front of it right now) that the left dial works the right arm and the right dial works the left arm.

These are all irritating problems esp 2 and 3.

Does anyone have any thoughts on this?

Big temptation to take it back and save up for V3 instead.

Also one other minor Q - in Control mode are there supposed to be four functioning direction buttons or eight as shown on the remote? [or are the extra four "diagonal" direction buttons only for Arm mode?]

Thanks

 

 

 

Nocturnal
Nocturnal's picture

Not a lot you can do to fix the walking, you can fiddle a bit with the pads at the bottom of the feet, adding weight to one side. You may find this thread interesting, I'm pretty certain aragon has identified a design flaw that will cause almost all RS Media's (and possibly V2's) to walk in circles.

I haven't had that problem myself, but I haven't left him in free roam mode for long, so I can't really say if its normal or not, it sounds very much like he's responding to his own motor noise. Have you tried disabling the sound sensors before switching him to free roam mode?

*Laughs* You have identified one of my pet peeve's about WowWee's designs, left and right are reversed. I assume it comes them assuming people are too stupid to realized left means his left arm, not yours. It made sense it the original RoboSapien since the remote had pictures on it, and you would (Presumably) be standing in front of him looking at it. Have you had trouble with scrolling the menu in Media Mode? there's somewhere they should have inverted the controls.

In control mode, for walking, I believe there are only four. 

MightyProtonB
MightyProtonB's picture

Nocturnal,

 Thanks for that.

The walking in circles isn't disasterous. It's at least tolerable anyway.

The free roam shut down - I read something since posting on robosapien.tk re the V2 that seemed to say it shuts down in free roam mode after 5 mins if there's no other remote input. If true seems to defeat the object of free roam.

I also read a review on RSM where reviewer said they left it going all day in the office and it managed 50m in total or something. In comparison with that statement certainly mine is lacking. But it's not so much a shut-down thing. It's the fact it gets into this loop. I did think about shutting down audio sensors to see if it makes a difference and will try that.

BUT then you say to yourself why would you want to shut-down any part of the sensors just to get a mode working. Seems a bit dysfunctional esp if you wanted to try to get it patrolling around or something and still responding to noises.

Re the inverted controls you are telling me it IS a design feature !! And I was just being flippant............ That really is a dumb design. It sort of makes it workable if you are standing in front of it. Totally illogical if standing anywhere else. Is there any way to hack this to fix it?

 Also do you know whether hidden features info on robosapien.tk works for RSM as well as V2?

 thks

 

Nocturnal
Nocturnal's picture

All WowWee bots will shut down after a while without input from the remote, this is a battery saving function.  As far as I know, the hidden feature info on the robosapien.tk site is specific to the V1.

Ask yourself, why, when in free roam mode, do I want his audio sensors on? especially beause they are supposed to disable when he moves to prevent him reacting to his own motor sounds. Which makes it really odd the he is responding to them to begin with.

Everything is done for a reason, the remote is probally the way it is to make things easier for kids, (personally I don't believe in making things easy (easy things do not encourage thought) but thats just me making stuff up. All WowWee bot's are like that (one hopes the dragonfly follows the traditional layout for model flight), so one assumes there is a reason for it SOMEWHERE.

If it REALLY bothers you, get yourself a microcontroller, stick it in between the IR LED and the controller CPU, program it to watch for the left / right IR signals and send the opposite one. For me its not worth the effort, I dont spend a lot of time using the remote. I spend a lot of time using a screwdriver.

MightyProtonB
MightyProtonB's picture

An update from this evening's experimenting :a) reading the manual we find that i) RSM turns ON vision and audio sensors when put into free roam mode; if they were off before then it returns them to off when free roam is exitedii) RSM is supposed to exit free roam after 10 mins and power down (wonder how that review team got it wondering around the office all day)b) oddly RSM seemed more active this evening. Before if you turned it on and did nothing it would do likewise; just sit there awaiting instruction. Tonight it occasionally moved and looked aroundc) it also entered it's listening loop cycle from this normal pending status ie not in free roam. Not a great development. d) I tried turning off audio sensors but per a) i) above it was an academic exercise. Tomorrow eve I have to try turning them off and leaving it in normal mode to see if it then enters the dreaded listening loop. Will post what happense) found guard mode is entertaining and found you need to make a loud noise for it to register a guard breach. Since room is otherwise quiet it's odd that it seems to hear something at other times on go into the loopDo we know a timeframe for RS V3 and per different threads is it Segway powered or does it have knees and the ability to climb stairs?thks

Nocturnal
Nocturnal's picture

a) Yes, I see that in the manual. It's wrong (I'd guess they got confused with Guard Mode), or my RS Media is broken, since he will not respond to any noise that I make no matter how loud, or close to his sensor when in free roam (and btw I tested it before I suggested it).  He turns  his "Vision" on, because that is useful for object avoidance, noise detection doesn't really add anything in the way of avoidance or moving. It does however turn them on in Guard mode, for obvious reasons. The reviewers probably exagerated a little.

b) My RS Media just sits there, unless there is some IR noise in the environment (or actual noise occasionaly).  

d) Academic or not, what was the result?

We don't know a time frame for the V3, we don't know what it will be when it is released. However it's supposed to have leg's, the segway tech was in P.E.A Bot. 

  

MightyProtonB
MightyProtonB's picture

a) if I turn off the audio sensor in regular mode it does appear to not hear anything. However even with audio on you have to clap loudly for RSM to register the noise. It is hard to be certain what it does in free roam mode because I'm got the view now that mine is faulty. It does still do the stopping thing mentioned above and gets into it's loop where it says "did I hear something" or equiv for the relevant personality. You'd have to assume that message is triggered by it hearing something. Then it says it must have misheard and then repeats. Sometimes - very occasionally - it gets out of the loop by itself and keeps walking. Sometimes -equally rarely - you can make a noise and movement around the time of the twitch and loop restart and it seems to cause RSM to get out of the loop. Otherwise it will keep mumbling to isteslf seemingly indefinitelyb) in test this evening RSM didn't go into the loop when standing there in normal mode. Most times it just sat there. A couple of times it moved its head an/or body as though tracking something. After just a couple of minutes standing there it went into sleep mode. After a while longer, maybe 10 mins, it powered down.d?) it was an academic exercise in free roam mode because I'm sure the sensors are turned on going into this mode and that some noise or false trigger from these sensors is what causes it to say it heard something per a) aboveBottom line is that it seems a bit flaky to be honest. I can tolerate all of he quirks for the general neatness of the whole thing but the tendency to slip into a seemingly un (auto) recoverable loop and just keep stating the same thing over and over again is just annoying. I think it may have to go back to the store.V3 stills sounds very interesting. A fellow gadgeteer and I were discussion at work (we work at an engineering consultancy) and I wonder whether there is a way to submit suggestions to Wowee for suitable features. It seemed to us that getting a reasonably priced domestic bot to reliably - just for Eg - recognise the fridge, open it and bring a beer is probably a big ask. But if it had wi-fi/wireless and a camera and if the rmote had a screen instead of or in addition to the bot then a user could steer it to the target. Small electro magnets in the hands might be neat too. And something that enables it to move faster on flat surfaces. Eg retractable wheels in the bottom of the feet. Etc Etc EtcAll further thoughts welcome !RgdsMark

Nocturnal
Nocturnal's picture

Further experimentation with free roam shows that his sensors are off while he is moving, but when moving around he will occasionaly pause. During that time his audio sensors are active, and he will respond to sound.

Whats causing your RS Media to loop? Faulty programing? Faulty circuitry? who knows. (Though personally I would love to crack open your RS Media's head, disconnect the Mic's and see what happens) Its probably not really something that can be fixed, I would suggest you return him. I wonder, does your RS Media make the heartbeat noise (it comes from the woofer)? I recall in the V2, the mic's had padding on the interior, I don't recall if the RS Media has the same padding.

Everyone has a wish list for the V3, and most of them are different (Though a lot of people seem to want knee's) 

MightyProtonB
MightyProtonB's picture

Yes agree mine has done the pause too. The problem I have is that when the pause happens sometimes he will appear to be assimilating the available data and then moves on, other times he picks up on a perceived sound and goes into this loop thing.

I'd agree with your diagnosis. I think it's either a sensitivity problem ie setting wrong somewhere or an actual fault  - poor connection, noise, etc. Not sure if it could be programming since I'm sure the load is bulk installed as an image.

 Thinking about it at the end of the loop cycle it does try to move, does a sort of both arm brief movement that comes over as a minor twitch and then returns to "hearing" something.  Maybe it is somehow picking up the noise of those motors. Doesn't explain why it doesn't do it all the time though. It does make the heartbeat noise some of the time but more noticable when booting up. During regular use it's not noticeable at all but then who knows whether it is getting amplified in the chest cavity? !!

I think it will have to go back you're right.

Thks for the thoughts.

CABBAGES
CABBAGES's picture

is the hearbeat noise a fault ? mine does it when you turn it on is this ok ? ive also seen mine do that hearing loop thing but i think it may have been the batteries were a bit low. I will maybe mess about with him a bit today to see if he does it again.

Nocturnal
Nocturnal's picture

Hard to say, its not mentioned in the manual or anything, but it ismostly constant. It could be intentional, and it could beunintentional. All RS Media's have it (it can be hard to hear, since itnot very loud).

John Grist
John Grist's picture

My RS Media does the hearing loop since I replaced the batteries.

Stalvros
Stalvros's picture

I was reading in a site saying something to improve rs media's hearing by plugging something like a mic to the jack-in of the rs media. hadn't try it yet though cause it also state that it might damage the rs media's hearing chip