Rovio Re-Connect Issue

53 posts / 0 new
Last post
Tatay
Tatay's picture

Jgamble257 said:

Tatay said: I have a similar issue. I also have a fixed IP so I don't think changing lease time will fix anything because DHCP is now out of the picture. DHCP is even turned off in my Dlink. When Rovio goes offline, the light still shows green (connected) but unpingable (deader than a door-nail), so I think this is a firmware issue. Although it has increased in severity when changing to WPA from WEP. Same as the above comments, power cycling brings it back to life, for a few hours. Based on the fact that this is happening to both Cisco (Linksys) and Dlink indicates more than a singular AP incompatibility. Other wireless devices in the home are not affected, just Rovio. Running the latest stable FW.

I appreciate the logic of dismissing the lease time change.  I, too, have assigned a static IP to my Rovio, but I also lengthened the lease time and have greatly reduced the going offline problem.  I can't explain it, but perhaps the re-leasing process impacts the Rovio connection whether or not Rovio has a static IP.  Maybe the signal's sent out to other IP devices causes the problem.  I confess that if you have turned off DHCP, your situation may be different.   

I suppose the one way to baseline this is to run something like ping-plotter and get actual measurements for how long the unit stays online. Lease times work this way. I use to administer a CNR (Cisco) DHCP server. That was a long time ago but the painful memories persist ;)

A lease time of say 4 hours does not mean that you will be hunky dory for 4 hours. It means that 50% of the way into the lease, your machine will receive a packet from the DHCP server asking if you still want that IP. If your machine responds then the lease is marked for another 4 hours at the end of the lease time and all is well. If your machine fails to respond then you still keep that IP for the full 4 hours but the DHCP server will reclaim that IP.

 

Now this is where you have to be careful and not trust some vendor on how they are complying to RFC 1541 or RFC 1542.

If you are not using DHCP you should either make darn sure your static IP is outside the DHCP scope or range, or just turn it off, becasue the following can happen, and again this is relative to the Rovio - AP DHCP server behaviour, (more the AP DHCP server's behaviour).

Say you use a static IP that for what ever reason the DHCP server identifies as a problem.

It may have provisions to put that IP into a dead pool. This is a irritating thing for administrators and we run scripts on crappy DHCP servers to release these IPs from this "dead" state because one bad client can eat up IPs from the pool.

Also depending on the APs code, say a Dlink or a Linksys, there are some interface provisions to handle static IPs where there shouldn't be. many routers have a provision to blackhole routing if they see  DHCP-OFFER packets but the host has a static. This is normally on the big boys, Cisco 7600s, ERXs, etc, but its in RFCs.

Sorry for the long winded babble, but what I'm enphasizing is that if you are using a static IP that is definately outside the rage of your DHCP pool and by adjusting a lease time your symptoms are affected then I would strongly suspect an AP issue because that simply is outside DHCP spec.

By using an IP that is not leased then there is nothing for the client to respond to.

Again, sorry if  if this come across as nerdy, but the issue got the juices flowing ;)

 

Gnattycole
Gnattycole's picture

Tatay, thanks very much for the info. Just to get this clear in my addled head here. If I am having these problems, would selecting a IP address outside the DHCP range for the Rovio fixed address, offer a cure? For instance. I have 5 PCs plus a PS3 and the odd laptop that comes into the house from time to time. My router default was set up to lease from xxx.xxx.x.100 and maximum number of 50. So I assume this means that (last 3 digits) 100 - 149 will be allocated by the router as clients connect. I also fixed 2 addresses for Rovio and Spikey 108 and 103 respectively. Do I need to select IP addresses beyond 149 to make your above suggestion work? In reality, I reckon I might restrict the range to less than 50 as I'm not exactly running an Internet Cafe from home. (See screenshot attached for info. If I can work out how to attach it). Any info appreciated Tatay as one mans Nerd is another mans expert. Regards, Nat.

Mich
Mich's picture

All,

Since I lengthened the lease time on the router I had no more connection issues. Rovio is available at any time from outside also.
Its IP address is fixed and set in the upper end of the DHCP address range.
Eventhough, as Tatay explained, the lease time length may not make a difference with fixed IP this has worked continuously.

For Gnattycole, I suggest you move your rovio to the higher end of the range, say 148 or 149 or 150. Leave the lower end for DHCP assignments.
By the way I have other devices with fixed IP and they are all clustered at the end of the range.

Gnattycole
Gnattycole's picture

I bought a Netgear router off Ebay a few days ago and have had no issues over the last two days since setting this up. Still early days but if this will go for a week plus I'll let everyone know. I guess this should indicate whether the router or the Rovio is the common denominator. It's set up the same as previously with the Linksys but the default IP addresses seem to be xxx.xxx.0.xxx instead of the Linksys's xxx.xxx.1.xxx. Whether this has any bearing I don't know. Also, external access to both Spikee and Rovio has worked without a hitch so far. Know anyone who wants to buy a Linksys router?????

Tatay
Tatay's picture

Gnattycole said:
Tatay, thanks very much for the info. Just to get this clear in my addled head here. If I am having these problems, would selecting a IP address outside the DHCP range for the Rovio fixed address, offer a cure? For instance. I have 5 PCs plus a PS3 and the odd laptop that comes into the house from time to time. My router default was set up to lease from xxx.xxx.x.100 and maximum number of 50. So I assume this means that (last 3 digits) 100 - 149 will be allocated by the router as clients connect. I also fixed 2 addresses for Rovio and Spikey 108 and 103 respectively. Do I need to select IP addresses beyond 149 to make your above suggestion work? In reality, I reckon I might restrict the range to less than 50 as I'm not exactly running an Internet Cafe from home. (See screenshot attached for info. If I can work out how to attach it). Any info appreciated Tatay as one mans Nerd is another mans expert. Regards, Nat.

 

I would be a little concerned
about the fact that you have your static DNS inside the range of your DHCP
scope. For the most part if I use a static DNS then I use the outside real IP
DNS for my provider. Otherwise I leave that field blank and let the Dlink or
Linksys choose. If I let it choose it should have the automatic smarts to
choose something outside the DHCP scope.

For the most part it should be ok
if the following criteria is meet:

  1. Nothing contends for those addresses.
  2. The DHCP server is light weight and does not
    have any routines for erroneous IP error checking.


# 2 is the key. As per my longwinded previous post, just work through the logic.

Another one of your machines comes online and requests an address, your DHCP server goes, "103 is free in my pool" and hands it out. If the DHCP server is light weight and has no routines to check the validity first then this will happen and then BOOM,you have two machines on the same LAN with the same IP. The IP stack on the device will probably complain and hopefully give you and error.

If the DHCP server is so light weight that it allows this then it will probably not even know something is wrong. Your banking on your WRT54G to recognize that you have used up two addresses from the pool as static DNS.


Mich
Mich's picture

Gnattycole,

I am not so sure this is the best way to have a static IP for Roveo!!!!

I fixed the IP from roveo rather than the router.

The DNS addresses are not for your local network ( my understanding). Just set the fixed IP in the client ( Roveo) and the DHCP will always grant the requested address.
Give that a go.

Gnattycole
Gnattycole's picture

Hi Tatay, that probably explains why the Netgear isn't having any issues as the default IP range is diferent by the 3rd set digit being a zero instead of a one. This will naturally throw the already assigned fixed IP addresses of the Rovio and Spykee outside its asignment range. Strangely though, the Netgear router seems to be much more reliable when gaining access to the Rovio from outside the LAN,(over the Internet). For some reason, the Linksys would sometimes just refuse to allow connection even if the rovio was still connected. Although Spykee appeared a bit more reliable, it wasn't a 100% guarantee either. Since the Netgear has been working, it seems to have worked every time I've attempted. Whether this means its less secure to attack from undesireables, remains to be seen. They've been available for 4 days without hitch so far so fingers crossed. The Netgear also has 8 available Ethernet ports which means I don't have to arse around swapping patch cables when Wii/PS3 gets moved from lounge to Bedroom and back again etc. I reckon it would be cheaper to just put the kids up for adoption personally, but my missus won't oblige. Thanks once again for the info Satay.
Regards, Nat.

Tatay
Tatay's picture

The big reason for static or DHCP is simply to load the IP stack of Rovio with the proper information. As long as Rovio has an IP and the correct gateway.
You could probably even get away with no DNS unless you need Rovio to resolve names for some reason. So Rovio should be a no brainer.

Mich, I have no doubt the lease is working for you but it is strange.

Gnattycole, I'm not too sure what your referring to with the Netgear and separate IP block.

Here is some networking 101 stuff

If router one has an internal network of 192.168.1.0/24 then you must provision your Rovio with an IP out of that block, i.e. Router gateway of 192.168.1.1 and an IP for Rovio anywhere from 192.168.1.2 to 192.168.1.254.
If the router like your netgear is setup to use 192.168.0.0/24 then you would have a router gateway of 192.168.0.1 and an IP for Rovio of anywhere from 192.168.0.2 to 192.168.0.254. You can't mix and match.

Most routers will let you set the LAN IP range and you can put in what ever you want. The IPs that they use are what is referred to as RFC-1918 space or private. Ranges are:
10.0.0.0/8
172.16.0.0 - 172.32.255.255
192.168.0.0/16

Some may even permit you to plug-in non-RFC-1918 or public space (very dangerous) but as long as it stays inside on your LAN then no harm no foul. Many big companies actually do this. I currently look after the management networks for a large telecom and this is exactly what we do. We use public space to tie our management networks together but we do not route this space on the Internet.

So Rovio simply needs it's own IP address say 192.168.x.y with the correct mask (many pages of discussion on masks), and the correct gateway 192.168.x.y, then you should be good to go. Note the "x" from 192.168.x.y in this example for both the Rovio IP and the gateway can be anything from 0 - 255, as long as both Rovio and the router are in sync.
Rovio - 192.168.0.2 - 254
Router - 192.168.0.1
Rovio - 192.168.1.2 - 254
Router - 192.168.1.1
Rovio - 192.168.2.2 - 254
Router - 192.168.2.1
Etc - all the way up to
Rovio - 192.168.255.2 - 254
Router - 192.168.255.1
One last thing is you don't even have to use .1 for the gateway address. This is just common practice and good housekeeping.
If I wanted to i could use:
Rovio - 192.168.0.1 - 253
Router - 192.168.0.254
I can use any IP in the subnet as my gateway as long as I don't use it for a host address. I could even do this.
Rovio - 192.168.0.1 - 110, 192.168.0.112 - 254
Router - 192.168.0.111

Pilotjunky
Pilotjunky's picture

I am having the same problem. Rovio docks, then after about 5 minutes it cannot be accessed. I can ping it, but I cannot access it to move it around. I have a static IP on it. The only solution seems to be cycling the power. I have updated to firmware 5.03 but that didn't help. Is returning the device as defective the only option? I wish there was a fix because otherwise the device is pretty cool.

Hollywood
Hollywood's picture

Hello, I am Paolo.
I have read all the post and I think that I have 2 problems. The first is this:
This seems to happen both when I'm trying to access Rovio either at home through my own wifi network or remotely through an IP address. Rovio is docked and the battery is full but after a long period of non use Rovio seems to lose the IP address. Anyway, I set up a static IP so it should remember what IP address it is. It is only when I power cycle Rovio that I am able to access it.
The second problem is that I have a fastweb router and cannot access inside for configure the dhcp. I have the firmware out of the box; is there an upgrading that resolve my problem? Anyone have fastweb router in Italy?
THX

Pilotjunky
Pilotjunky's picture

Hello,

After several hours of research and evaluation of the reconnect problem I contacted Rovio technical support regarding the issue. After explaining the loss of IP (Static or DHCP) and giving very specific firmware and timing details I was given a very technical response. It went something like this...

"Please return Rovio to point of Purchase".

I think Rovio either had/has a manfacturing problem or a design issue... there appears to be no current solution.

I am anxiously awaiting the next Rovio version because it's a great concept.

So, stop trying to fix it, because you apparently can't with at least a certain batch of units.

Thx.

Hollywood
Hollywood's picture

It's impossible for me I have bought Rovio on Ebay :(. But the latest firmware upgrade do not resolve the problem?

Pilotjunky
Pilotjunky's picture

Firmware upgrade would not resolve the issue as of a couple months ago. In fact if there was a firmware update that would fix it, I suspect they wouldn't have instructed me to return it.

Try contacting support with specific model and revision number of your device... maybe something has changed in the last couple months.

Hollywood
Hollywood's picture

Mich said: All, Since I lengthened the lease time on the router I had no more connection issues. Rovio is available at any time from outside also. Its IP address is fixed and set in the upper end of the DHCP address range. Eventhough, as Tatay explained, the lease time length may not make a difference with fixed IP this has worked continuously. For Gnattycole, I suggest you move your rovio to the higher end of the range, say 148 or 149 or 150. Leave the lower end for DHCP assignments. By the way I have other devices with fixed IP and they are all clustered at the end of the range.

You have resolved the problem with new lease of DHCP? My Rovio lost connection 15 hours exactly after first access. My problem is that i cannot access on my router FASTWEB for increase lease of DHCP.

Hollywood
Hollywood's picture

I have resolved the issue with static IP. The fastweb router seems that not release the IP that I have put in ROVIO.

hhspiny
hhspiny's picture

I have been having the loss of connection after idle problem for long time. tried a different method and even had a replacement unit. but the replacement unit has the same problem too. what I found out is that if I keep pinging it, it would be fine. so I would guess the rovio network card just goes to "slee" for inactivity and does not wake up anymore.

I have my router ping it every minute, seems to work fine.

Joe_in_MO
Joe_in_MO's picture

Rovio 'times out ' even during use after about 1 minute, requiring cold boot to reconnect, I can reconnect only during a 1 minute window, then Rovio times out again.

Problem is consistant if on same network/subnet or external using port forwarding.

Updated firmware to 5.0.3 stable, problem persists.
Other remote IP based devices on network function perfectly, i.e. wireless IP cameras, wireless printer, etc.

Router = new Linksys e2000
PC= dell e6410 os = Windows XP sp3,

Please advise.

wizzelpaul
wizzelpaul's picture

hi everyone does anyone know how to setup the rovio on a mac ive gone through the steps on youtube but when i go the installation and i get to the end of it i cant connect to it on the web it says on mine that the connection is takeing to long

sw232572
sw232572's picture

As someone else mentioned, I am SO happy I am not the only one with this problem, where my Rovio (that I just bought on eBay for $90) drops the internet connection after ~3-4 hours. I have the benefit of course, of reviewing four years of messages to spot some trends - it seems to me, most people impacted are on a Linksys (I don't know if we confirmed that was the problem) - which I am as well (Linksys 1500). It also appears to not be a problem with the Rovio, rather the router settings? I did move the IP outside the DHCP range as suggested, and increase DHCP lease time to the max of 9999 minutes. If that doesn't work, I'll try the ping option - and my last resort: Putting a timer on the A/C outlet to let the Rovio battery drain to zero overnight, and then start it up again in the morning (which effectively, turns it on and off).

I am really hoping the IP option works, or maybe I get a new router. If anyone has come up with new theories on this issue, do let me know - I just hope I didn't just buy one of your faulty Rovio's :-)

Gnattycole
Gnattycole's picture

Hi SW,

Welcome to the forum. I have a Netgear router and whilst it was a pain to set up the port forwarding etc initially, it didn't drop the connection like it used to with the Linksys. I've been meaning to dust off my Rovio and get it running after a recent housemove so I'll let you know how I get on with a BT supplied router (BT Homehub 4).

Good luck and let us know how you get on.

Regards,

Nat.

sw232572
sw232572's picture

Thanks Nat! Turns out setting a static iP outside dhcp range and increasing lease time does NOT fix the problem. Still dropping connection which totally defeats the purpose of this thing... Looks like I need a new router which is a shame because its a perfectly good one too...

sw232572
sw232572's picture

Hey guys, so I think I have finally cracked this nut, unfortunately after buying two mini WIFI cards (someone said you can replace it). I've done a barrage of tests as I was committed to get this thing to stay connected.

Turns out, by never using the browser interface (only tested Chrome though), it will stay connected. Instead, if you ONLY use the iphone app (though it's $4.00), it will stay connected (so far on 9 hours which is a record).

Something about the browser kills the connection after a few hours... even closing the browser didnt do it. THoughts ???

Pages