RS Media Dev Kit 1.1.1 online. Do not use earlier versions!

4 posts / 0 new
Last post
TikaC
TikaC's picture
RS Media Dev Kit 1.1.1 online. Do not use earlier versions!

Thanks to Nocturnal and Santa Matt, I've updated the RS Media Development kit and it's now online. To read more about the errors and problems the previous versions had, see this thread:

http://www.robocommunity.com/forum/thread/15530/Nocturnal-s-Firmware-Dum...

Do NOT use versions earlier than 1.1.1. Please get the latest verison.

I'm planning to work on text-to-speech next, if I can get flite working, and going to work on the speech recognition as well.

But today I think I'll work on the Dev Kit page so it's less like a long article and more readable.

 

TikaC
TikaC's picture

Ok, I've updated the RS Media Dev Kit page too. Hopefully it's more readable. I've also outlined on the page what I'll be working on in the future for this project.

Helibot
Helibot's picture
Hi Tikac,
   This is Helibot (from Unofficial RoboSapien Hacks and Mods Forum). Great job on the Dev kit. Its a great idea that will allow other RSMedia users (without the serial/console hack) to access, experiment and mod RSMedia.
   I have a few suggestions for you that you may like to add to a future version?
 1) During section Part 2:Obtaining the Robot Firmware Files you say to wait for ten minutes.  By changing the script you can make MS media display a picture on his screen before starting and a different picture after finishing. (The 1st picture could contain text 'Copying files please wait...' and second pic 'Completed - please remove SD card').  This should make it a lot easier and safer for new comers to use.  Credit for this should actually goto Nocturnal, I saw that he did it once in a SDcard format script. 
  I have tried it with your rsupdateapp script and it worked OK for me. (If you would like the script let me know I can paste here it or email it to you).
 2) The devkit reads as a sequential set of steps - you get all the files from the robot, you look at the files using Linux (existing or VMWare), you setup the Arm Dev system then you compile a program.  But some of these are actually independent, you could do get the files without setting up the dev env. Or you could setup the dev env without getting the files.  Maybe you could split the doc into two parts?  Just a suggestion.
And finally a question?
   The Redhat VMware image has a default Samba share setup which can be mapped as a windows drive. Would this be easier than using WinSCP to copy the files?
(BTW It should work if you run the VMware session then map a windows drive to  \\<<vmware_ipaddress>>\vm_user and use username=vm_user,password=vm_user when prompted.  <<vmware_ipaddress>> = the ip address you got from Part5 Step 11 in the DevKit.)
Anyway great work, I hope it encourages more people to get in there and mod away!. 
Also thanks for the mention in the credits section of the doc - its appreciated :-) 
 
Cheers
     Helibot
TikaC
TikaC's picture

Helibot! Thanks for popping in! And thanks for the info you posted over on the other forum. I appreciate the input as well.

#1: The script to do the dump came from Nocturnal. I didn't get a screen display script with it so I would like that. This script pretty much freezes the screen display when it's running so yeah, having a special display would be most helpful (and more user friendly). You can email it to me if you wish. My email I'm going to de-spam it so here it is the clues (easy to figure out :) ). My domain is ByteBin.net (that I think you know) and send email to that domain using the username "webmaster".

#2: The docs are split up into several parts. You could use Part 4 in the docs to set up a dev system. Right now that is about how I'll keep it. As the SDK grows, I'll probably be changing the documentation and the format a few times. The documentation I like to keep in one file for easy use. However, the docs are split up into 8 parts. Actually 9 if you count the extra stuff at the end.

And to answer your question, I did try to use the Samba but on my Windows Vista machine, it did not find the system and I did have the proper login info. The problem is that Windows Vista uses MACHINE_NAME/USER_NAME and samba does things differently. So it might not even be compatible. I don't know. All I know is if it doesn't work for me, I'm not going to add anything in if it doesn't work. So that is why I put the WinSCP in there.

Thanks for the input and I would be grateful to have that extra info on how to make display screens when the firmware dump script runs.