[Solved] HELP: RS Media stuck at WowWee splash [video]

57 posts / 0 new
Last post
Helibot
Helibot's picture

Hey Freddy,
On your BT device does it have connection points? I can seem them in the photo? Maybe they are on the other side? What markings do they have?
BTW the winding track at the top will be the arial for the transmitter/receiver.
Cheers
Helibot

FreddyA
FreddyA's picture

Helibot, there are many contact points along the sides and bottom (oposite to the antenna)but no markings. trying to find a data sheet for it. will update ASAP

Freddy.

FreddyA
FreddyA's picture

OK Here is a picture about the pinout:

http://imgs.inkfrog.com/pix/szhonstar/pinout.jpg

How to change the Baud Rate:

Send: AT+BAUD1

Back: OK1200

Send: AT+BAUD2

Back: OK2400

......

1---------1200

2---------2400

3---------4800

4---------9600

5---------19200

6---------38400

7---------57600

8---------230400

A---------460800

B---------921600

C---------1382400

Freddy

Helibot
Helibot's picture

Hi Freddy,
From the pinout you proveided I guess you need to connect :-
BT Pin1 (TX) to RSMedia Pin2 (Rx)
BT Pin2 (RX) to RSmedia Pin3 (Tx)
BT Pin13 (BNG) to RSmedia Pin6 (GND)
BT Pin12 (3.3V) to batteries or RSMedia Pin1 (3.3v) or other 3.3v source.
BT Pin11 (Reset) you can probably leave this unconnected?

Notice that the Tx (output) from the module goes to input (Rx) on the RSMedia.
And the Rx (input) on module goes to output (Tx) on RSMedia.
This is probably right... but some modules mark the TX as input and RX as output. So check the docs to see if TX is an output , if so use the above connections. If TX is an input then connect Tx to Tx, Rx to Rx. If the docs dont say, then try the above first, if it doesnt work then try the other way round!

Regarding the reset pin - you can probably leave it unconnected, but its possible it needs to be tied to 3.3V or GND. See if you can find about this in the data sheet.

Good luck!

Cheers
Helibot

Helibot
Helibot's picture

Hey Freddy,
Sorry , forgot to mention about the Baud rate.....not sure if you need help on this but I tell you what I guess anyway.....
Ideally you need to set the module to 115200 baud. But in the commands you listed 115200 is not listed :-( ....Bummer - you may have to use 57600 and the baudrate change program I wrote for Jamie (I think?).
I guess the module will likely default to 9600 baud (or something low like that). So you may need to connect it to something else to send the AT+BAUDx command at this low speed.
So I suggest that you actually connect the BT module to you new usb2serial device and then you can use teraterm to connect to the usb2serial device and send commands to the BT device. Does that make sense?
Actually this would be a good way to test your BT device. Connect the USB2serial TX to BT RX and USB2serial RX to BT TX and Gnd to Gnd. Then use some batteries to power the 3.3v on the BT module. Then you sould be able to use Teraterm to connect to the USB2serial com port. Then use Bluetooth to connect the BT device to the PC (this should create another Com port). Start ANOTHER Teraterm to connect to the BT com port. Then you should have two terterm windows and when you type in one it should appear on the other and viseversa.
Make sure you set the USB2serial Teraterm to the same speed as the BT teraterm (ie 57600) if you receive garbage when you type then BT device is porbably not set to the correct DTE speed (And you have to use the AT+BAUD command)
.
Hope this helps (and I explained it OK!)!!

Cheers
Helibot

Helibot
Helibot's picture

Hi Some1I8,
Sorry I have just reread some of this thread and now realise better what you are trying todo. If you want to run the media board standalone (ie not connected to anything other part of the robot) then you can supply power to it by connecting 3.3v on pin1 and gnd on pin6. And connect TX/TX to get the serial console input/output. I have done this successfully before (when I had to bootstrap and reflash the firmware).
But I would not suggest connecting anything else (eg LCD or other connections to other robot parts) when powering the board this way.

Cheers
Helibot

FreddyA
FreddyA's picture

Helibot, here is where I am at. I get the console up for USB2Serial at 9600-1-n and the BT console up at 9600-1-n. I can type in the usbserial and I see it in the BT console and vise versa. However, it seammingly does nothing with the command, AT+BAUD8. So the devices are talking but something is wrong there. According to the listing;
Default Baud Rate: 9600,8,1,n.(1200????Œ2400????Œ4800????Œ19200????Œ38400????Œ57600????Œ115200 you can change it by yourself)
And so with that in mind, 115200 would be AT+BAUD8 But I dont get back an OK115200 or anything for that matter. So even if AT+BAUD8 = 230400 it would come back with OK230400 right?
Anyhow I know that my post has 8 = 230400 but looking at the listing that may be a typo (I HOPE)
Any suggestions on why I am not getting back any OK?
Freddy

Helibot
Helibot's picture

Hi Freddy,
Doesnt sound like you are having much luck. Not sure what the problem maybe , but heres a couple of ideas to try:

-A modem style device often needs a '+++' to get back to command mode before a ATxxx command will work. So you can try this as well - just type three + symbols as quick as you can , one after another.(Dont hit return). This may cause it to return a 'OK' prompt? If so then use the AT+BAUD command. (an ATO command may make it go back into data mode)

-Maybe the recognition of 'AT+BAUD' is disabled when the device is fully online and connected. So try disconnecting the Bluetooth side (ie unpair the BT device from the PC) but leave the serial lines connected to the usb2serial device.
Then from usb2serial com port try the AT+BAUD8 command.

-Maybe the OK115200 is sent at the new speed (ie at 115200) so if you are still connected at 9600 you may not see return value.
You could try using AT+BAUDx (where x is the number for 19200) and see if you can get it running at this lower speed.

-Are there any other AT type commands supported? AT&F is often a 'reset to defaults' command. Or 'AT' or 'at' may get you an OK prompt. This will at least tell you it is receiving commands.

-If none of the above helop and you have got a manual, then email me a copy and I will have a look over it , see if I can come up with any other suggestions.

Cheers
Helibot

FreddyA
FreddyA's picture

OK some good news all around. First, I upgraded my UK v1 to a v2 with Jamie at the wheel as I trusted him and I sat back and watched as jamie took my RSMs life into his own hands. That turned out great. Now after a couple sessions I got 115200 on BT, Thanks Helibot, the trick was NOT pairing and start with default 9600, change baud rate AT+BAUD8, returns OK115200 and then moving to the RSM serial and all works. So I am at 115200 and 3.3v from the No.1 pad. totally awesome.

For this connection to the serial pads I used a floppy drive power connector and some pins. I have several of these so i can use the BT with my other RSMs. I also used the original packaging tray the chip came in and a plastic cover. To solder the chip was tricky as it is a side solder not a hole. So you must pre shape and pin each wire before soldering to the chip. Once soldered the wires should not move or you risk breaking off the tiny contacts along the side.

GET ONE! http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=270625898146&ssPageName=STRK:MEWNX:IT

Freddy

Jamie
Jamie's picture

FreddyA said: OK some good news all around. First, I upgraded my UK v1 to a v2 with Jamie at the wheel as I trusted him and I sat back and watched as jamie took my RSMs life into his own hands. That turned out great. Now after a couple sessions I got 115200 on BT, Thanks Helibot, the trick was NOT pairing and start with default 9600, change baud rate AT+BAUD8, returns OK115200 and then moving to the RSM serial and all works. So I am at 115200 and 3.3v from the No.1 pad. totally awesome. For this connection to the serial pads I used a floppy drive power connector and some pins. I have several of these so i can use the BT with my other RSMs. I also used the original packaging tray the chip came in and a plastic cover. To solder the chip was tricky as it is a side solder not a hole. So you must pre shape and pin each wire before soldering to the chip. Once soldered the wires should not move or you risk breaking off the tiny contacts along the side. GET ONE! http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=270625898146&ssPageName=STRK:MEWNX:IT Freddy

Hello Freddy,

 

This certainly is the best serial hack by far! This is a really great serial hack! And on your wired hack, using a headphone jack is very amazing. Great job! I like how you soldered the Bluetooth module so good. It looks professional!

 

I like all of your ideas and they turn out GREAT.

 

See you soon.

 

Cheers,

 

Jamie Kugelmann

FreddyA
FreddyA's picture

Hi jamie, thanks so much for your props. I'm really glad you like the hacks I've done and I really appreciate all your help all the time..

Freddy

Helibot
Helibot's picture

Hi Freddy,
You hack looks great. I have done the same with a 4 pin header on mine so I can swap b/n the Bluetooth and the serial connection - except that my 4pin header floats out the side of the robot - not as neat as yours!
If you are going to be moving it a lot, then maybe put a blob of silicon around the four ins to give them a bit more strength. Also you need to make sure you never plug it in the wrong way round - it will likely fry the BT module :-(

BTW - Do you have any data on the module - I'm curious how much current it draws - cos mine wouldnt work from teh 3.3v on RSMedia :-(
Cheers
Helibot

FreddyA
FreddyA's picture

Hi Helibot, I'm glad you liked the hack too and thanks for the advice. I used a bit of hot glue on the inside and outside of the pins and they are held pretty good and also have a pin 1 mark so I dont plug it in the wrong way. I could not find a data sheet for the module yet but as soon as I find it I'll foward it to you. Thanks for all the help to get it going, you made it easy for me.

Cheers
Freddy

Helibot
Helibot's picture

Hey Freddy, Hot glue is even better than silicon! No hurry for the data sheet, if you find it send it through....
Cheers
Helibot

Curtainmaker
Curtainmaker's picture

Hi Guy, I have got a Bluetooth BlueSmirf for my RSM 2. Do I need 3 wires like the usb hack or 4 wire connections like above.
Cheers Curtainmaker

gerber
gerber's picture

Hi Curtainmaker

You will need 4 wires for the bluetooth chip. The bluetooth uses the same wires as the usb connection but also requires a 3.3v power supply (Note: your bluetooth chip documentation will probably say it need 5v but it should work with the 3.3v which the media board supplies.)

Below is a picture to show the serial hack pads you will need to use for the bluetooth

On my bluetooth chip there is a led to show when the chip is switched on.

Hope this helps.

Cheers
Gerber

Curtainmaker
Curtainmaker's picture

Hi gerber

Great thanks for the pictures. I will do it tommorow
cheers curtainmaker

Curtainmaker
Curtainmaker's picture

Hi Gerber, Thanks heaps. I have hooked it all up and it works great. I have paired it up with my cell phone and also a computer. I will upload a few picture tomorrow of what I have done. now all I have to do is try it on your program.

Regards Curtainmaker

gerber
gerber's picture

Hi Curtainmaker

No problem. Glad you got it working. Have you got it working so you connect via IP address instead of com port. If not I totally recomend it as you can transfer file to the sd card on the robot with out having to remove the SD card and restarting the robot.

Cheers
Gerber

Curtainmaker
Curtainmaker's picture

 

as you can also see the back of the stereo jack that I use to attach it ot the other bot with the USB Plug.

 

Cheers Curtainmaker

gerber
gerber's picture

Nice mod

FreddyA
FreddyA's picture

Well done.

Curtainmaker
Curtainmaker's picture

Hi Gerber, Thanks.. I forgot to put that I havn't tried it on your program yet as my pc doesn't have bluetooth so i'm just waiting for a Dongle to arrive so i can set it all up. will advise.
and thanks FreddyA

Curtainmaker

Curtainmaker
Curtainmaker's picture

Hi Guys
Well I got my dongle and set it all up. I now have a Bluetooth RS Media.
It works on both gerbers programs. I can move its limbs on the control station and also see the bot scripts in gerbers Terminal console.

Just a question tho. For some reason the bluetooth connection on my pc made a com9 and com10, both are bluetooth and are for the RSM. is this normal??

cheers Curtainmaker

FreddyA
FreddyA's picture

Yes it is normal. Good work in getting up to this point. Now comes the fun. I've just beta the new RSMCS and it is really something.

gerber
gerber's picture

Hi

Glad you like the new software freddy. I will be posting a update of my progress with a video to show you some of the features available in the software. still got more work to do on the software but my plan is to have it uploaded to the forum no later than the end of October.

Not sure why there are 2 comports for each bluethooth dongle but as freddy said above it is normal and only one of the 2 comport numbers will allow you to control the robot.

Cheers Gerber

Pages