Need RS Media Help

8 posts / 0 new
Last post
ElectronicsGenius
ElectronicsGenius's picture
Need RS Media Help

trying to get a working RS media has finally happened for me (if all goes well putting him back together)

so long story short, via 2 RS media robots i made 1 good robot from 2 broken bots.

so now im left with 1 bad bot with 2 problems, in it i have a bad transistor on the motor driver board in the head control circuit and a bad media board.

so with the bad media board hooked up in the good bot, the bot comes on, shows loading screen.. then goes white... he sees me and tracks but no voice/sound screen stays white.

 

I am guessing he has had his bios wiped or something.

seems like remote works ok but again.. white screen.

 

i swapped media boards a couple times to verify it IS the problem.

i probably just need someone to point me to the right thread.

please help, i been crying all morning and im almost out of tissuesYell

FreddyA
FreddyA's picture

Hello ElectronicsGenius, try swapping out the head ribbons. I had this issue and for me it was the ribbon from the Con4 to the main board (below the motor board). And when you have a green screen in camera or video view that would be the con2 to AJ8 or con1 to AJ3. Hope that its that simple.

Freddy

ElectronicsGenius
ElectronicsGenius's picture

well what i did was put the bad media board in the good bot, and it did the same thing so i was thinking it cant be the ribbons cus they work fine when the good media board is in.

ElectronicsGenius
ElectronicsGenius's picture

also does anyone have a scrap RS Media driver board, i need one of the big transistors utc8772L or a cross referencing part number.

FreddyA
FreddyA's picture

Does enyone have any scrap RSM or V2 parts at all? Please PM me, any part is accepted haha.
The transistors are here http://www.robocommunity.com/forum/thread/17494/RS-Media-Fried-electroni...

Freddy

ElectronicsGenius
ElectronicsGenius's picture

 

ElectronicsGenius said: also does anyone have a scrap RS Media driver board, i need one of the big transistors utc8772L or a cross referencing part number.

actually i looked at it again with my camera and its UTC above D882L

 

im hoping its just an NTE 184

ElectronicsGenius
ElectronicsGenius's picture

got one on its way to me. tnx FreddyA.

ElectronicsGenius
ElectronicsGenius's picture

ElectronicsGenius said: trying to get a working RS media has finally happened for me (if all goes well putting him back together) so long story short, via 2 RS media robots i made 1 good robot from 2 broken bots. so now im left with 1 bad bot with 2 problems, in it i have a bad transistor on the motor driver board in the head control circuit and a bad media board. so with the bad media board hooked up in the good bot, the bot comes on, shows loading screen.. then goes white... he sees me and tracks but no voice/sound screen stays white. I am guessing he has had his bios wiped or something. seems like remote works ok but again.. white screen. i swapped media boards a couple times to verify it IS the problem. i probably just need someone to point me to the right thread. please help, i been crying all morning and im almost out of tissuesYell

ok after a lot of help from FreddyA, Helibot and others, THE BOT IS UP AND RUNNING! and working nicely ... here is what happened:

After starrring at the white screen for a few days, i found out that the media button was going thru the modes but i couldnt see or hear it... that is until i toggled to Media mode.

then i could see the media mode menus without sound, there were no java games and photos and vidoes were not being saved.. also volume would go up and down (it was all the way down) but still no sounds and the bot would also not remember where the volume was next time i rebooted (back to 0 volume again) BUT with the volume turned up i could get sound when i hit the demo button on the remote, he would do his dance and the music was fine but all the voice and music still did not work.

so then i activated usb mode and went into the bot's memory with my PC. uploaded music but it would not show up to play it and sometimes the bot would crash and require reboot.   i formatted the bots memory and when he rebooted still everything had the same problems so finally i copied all the files from my working bot to the bad bot and had the same problems.

at this point i figured my only option was to reflash the bot's firmware. so, even though this was a V2 RS Media, i tried to use the "Original RS Media firmware" for V1 and i could never get it to see the SD card. then i noticed my other WORKING Rs Media could not see my sandisk 1 Gig SD.

After getting a 512 SD from eBay, the bots could then see the SD and so i succesfully flashed my broken bot with V1 firmware.(does anyone have an RS Media working with 1 gig SD and could tell me what brand SD card it is so i can get some?)

After that, eveything works as it should and i am happy as hell. but this was a V2 and now it is a V2 with V1 firmware.

now i just need the V2 firmware re-flash which Helibot said he will make the script and upload here for me and eveyone else to re-flash a V2 and fix corrupted RS Media V2 firmware!

as for the shorted neck transistor, FreddyA pointed me to the cross reference part number and i purchased one and fixed his neck.

The way i shorted the transistor in the first place was: i tried to use a universal un-regulated power supply, the bot was working ok but then i smelled smoke when he turned his head and thats when it shorted and his head would always turn to the right and stay.

YOU MUST USE A [REGULATED] UNIVERSAL 7.5 VOLT POWER SUPPLY OR YOU WILL TOAST YOUR BOT IF IT IS NOT.

One more note, i recently purchased a Mr Personality cheap from ebay, it just so happens the power supply for a Mr. Personality is the exact same one as RS Media (part number and eveything). and since there is no reason to leave a Mr Personality plugged in (unless you are drunk or trying to kill yourself with bad jokes), i use it for my other RS Media and it works fine.

thanks again to eveyone, especially Helibot and FreddyA.