iPhone App: Rovio Control (now supports Apple Watch)

107 posts / 0 new
Last post
Chibi
Chibi's picture

Ah, gotchya. Thanks for clarifying!

Keep up the great work, man!

vinnie
vinnie's picture

@iTommy: just one button in the settings for AGC would improve the low-light levels - and allow Rovio control at night! :-)

Thanks again for the great app!

Bojangles
Bojangles's picture

Hey there! Chipped in my $4 to give it a whirl and support the renewal of the rovio community ;)

Works pretty well - though I think before I play too much more I have to try the battery charging fix...

I just got an ar drone 2.0 too and see you have an app for that - keep up the good work... soon I'll have my army of robots!

iTommy
iTommy's picture

Glad to hear that. Search for AR.Drone in the Store, I did a few more. And to make the robo apps complete I just released an iPhone app for Aldebaran's sweet Nao:

http://www.youtube.com/watch?v=oslVLBQSiJ0

(almost a bit off topic in this thread but since we all love robots...)

XRAY4
XRAY4's picture

Help, I can't get rovio to communicate with the program.

iTommy
iTommy's picture

Hello,

does the connection work with the normal web interface? If you are using default configuration and the Rovio is in the same network as your iPhone it will just work.

XRAY4
XRAY4's picture

Help, I can't get rovio to communicate with the program.

iTommy
iTommy's picture

Hello,

does the connection work with the normal web interface? If you are using default configuration and the Rovio is in the same network as your iPhone it will just work.

XRAY4
XRAY4's picture

Help, I can't get rovio to communicate with the program.

iTommy
iTommy's picture

Hello,

does the connection work with the normal web interface? If you are using default configuration and the Rovio is in the same network as your iPhone it will just work.

XRAY4
XRAY4's picture

Help, I can't get rovio to communicate with the program.

iTommy
iTommy's picture

Hello,

does the connection work with the normal web interface? If you are using default configuration and the Rovio is in the same network as your iPhone it will just work.

XRAY4
XRAY4's picture

Help, I can't get rovio to communicate with the program.

iTommy
iTommy's picture

Hello,

does the connection work with the normal web interface? If you are using default configuration and the Rovio is in the same network as your iPhone it will just work.

XRAY4
XRAY4's picture

Help, I can't get rovio to communicate with the program.

iTommy
iTommy's picture

Hello,

does the connection work with the normal web interface? If you are using default configuration and the Rovio is in the same network as your iPhone it will just work.

XRAY4
XRAY4's picture

Also, Im not sure if rovio is connected to my network. How do i find out?

iTommy
iTommy's picture

Allen is it possible that we are mailing at the moment about the same isse? We should stick to one communication channel. Either forum or email. For less confusion ;-)

gannboy
gannboy's picture

Hi guys,

I really needed some help here with my rovio...

I have read this thread, http://www.robocommunity.com/forum/thread/19172/Resurrecting-Rovio-A-Win...

and posted a reply too.

I have the following questions, hoping someone can kindly help me. Really appreciate it.

1) Will Rovio be able to work in Windows 7 x64bit system after I have successfully installed in Windows XP mode under Windows 7 x64bit system. I am using a PC rather than a laptop computer.

2) Or do I have continue run Rovio under Windows XP mode under Windows 7 x64bit system?

That's all for the moment.

Thank you.

Eddy

iTommy
iTommy's picture

Please note that this thread is about an iPhone app.

gannboy
gannboy's picture

Hi iTommy,

Hurray, I managed to get my Rovio working using the thread written by Proxygeek,

http://www.robocommunity.com/forum/thread/19172/Resurrecting-Rovio-A-Win...

I am able to see my Rovio on my firefox web interface using Windows7 Professional 64bit edition.

I am interested to get your iPhone app for my Rovio, but I have some questions:

1) Do you have any video tutorials on how to setup this app after installation?

2) Do you have an app that catered to the Android operating system. I am thinking of getting a Samsung Galaxy SIII?

3) If you do not have any video or written tutorial, is is easy to setup the Rovio as well?

Thank you.

That's all for the moment.

Eddy

gannboy
gannboy's picture

Hi iTommy,

I just paid for your Rovio control app.

I have some questions :

1) what is the host/port that I have to enter? I do not know what is this field.

2) what other info I need to enter?

Thank you.

Eddy

iTommy
iTommy's picture

gannboy said: (..) 1) Do you have any video tutorials on how to setup this app after installation? 2) Do you have an app that catered to the Android operating system. I am thinking of getting a Samsung Galaxy SIII? 3) If you do not have any video or written tutorial, is is easy to setup the Rovio as well?

Hello Gannboy!

1.) No. When the rovio and your iPhone using the same wifi network it will just work without any configuration.

2.) I'm not into Android.

3.) Local setting is as easy as it can be.

iTommy
iTommy's picture

 

gannboy said: 1) what is the host/port that I have to enter? I do not know what is this field. 2) what other info I need to enter? 

There are two profiles "local network" and "internet". In the "local network" profile you do not have to think about these values because the app will find the rovio automatically. (It will not even show you port and host) of course the rovio and your iPhone have to be in the same wifi network.

When you are using the internet profile you need to enter a host (typically a dyndns host) and a port which has to be forwarded in your router settings. Configuring external access can be tricky and you should stickt to the manuall or in forum threads because this is app indepentend.

Basically: When you did setup the external access you will know what to enter for host and port.

 

gannboy
gannboy's picture

Hi iTommy,

Thank for your reply.

I am staying in Singapore and I am working outside.

I have downloaded and installed your app on my IPAD on my workplace using 3G network.

I am still not able to connect to Rovio, I have some more questions :

1) Do have to be at home near my Rovio and my Linksys Cisco wireless router before I can use your app? as you mentioned that the app will find the Rovio automatically.

2) After I setup the your App, can I still use the App in a 3G network?

Please advise and thank you.

Eddy

iTommy
iTommy's picture

The app can find Rovios indeed only in the local network - not all over the world. You can use it over a 3G network only if you setup your Rovio for external access first.

This can not be done in the app itself, because it has nothing to do with it. I have to refer to the manual or several good threads here in this forum like http://www.robocommunity.com/article/14500/How-To-Set-Up-External-Access...

vinnie
vinnie's picture

@iTommy: I showed off your app with Robvio at an Atlanta Hobby Robotics Meeting and there were a lot of ooo's and ahhh's! Ebay continues to sell Rovio's new in box.

Is there any progress in adding a setting to "enable" the Automatic Gain Control and the "night mode" feature that extends the camera exposure time? The Rovio cameras can do it, but Wowwee didn't seem to know it was there.

These features would really make your app stand out, and greatly enhance the utility of it.

iTommy
iTommy's picture

I did not forget your suggestion. I've been busy but it's still on my list.

gannboy
gannboy's picture

Hi iTommy,

I have created a custom URL with DynDNS by following the thread below created by Peter :

http://www.robocommunity.com/article/14500/How-To-Set-Up-External-Access......

My Custom URL With DynDNS for my Rovio :

myroviogannboy.dyndns.org

When I entered my username and password that I saved with my "settings" on my Rovio interface. I am able to login using my PC's Firefox browser, but on your App, I am not able to connect.

I have keyed in the correct username, password and my custom URL in the "Host" field, and "Port" field, what do I put in that field?

When I cut and paste the custom URL onto my iPAD google chrome and safari, I am not able to connect, saying gateway timeout as the error message.

I am not able to see the login page, any idea what happen here.

Please advise urgently.

Thank you.

Eddy

iTommy
iTommy's picture

Gannboy, I have to admit that this is almost not possible to debug for me. If you can not connect with the app and also the mobile browser of the device something is blocking the traffic. Maybe it's worth a try to change the port to 80.

To keep this thread clean you can also contact me via email: www.digitalsirup.com

Pages