Fighting Ports/Rovio for 2 Years, No dice

4 posts / 0 new
Last post
ZekeGraal
ZekeGraal's picture
Fighting Ports/Rovio for 2 Years, No dice

I like many Rovio owners, am pulling out my scalp with what is left of my hair! I have 2 Verizon Westell modem/router combos and cannot figure out for the life of me why they won't let me connect from outside!

I will put up my EXACT configuration, in hopes that someone else will be able to help me.

Also, Rovio's IP is static, and my host has been used to host a temporary website so I have no idea why they won't work. Oh, and one time I had temporary success using DMZ instead of ports but.. nothing out of that either.

**To any forum admins here, I apologize if any of my images are unsatisfactory, I tend to get yelled at on forums a lot for doing stuff wrong..

1 - Rovio's Config:

Rovio Config

 

My Router Port Config:

antec
antec's picture

I understand your frustration! Rovio is an awesome product that, unfortunately, requires a number of third party hardware and software items to work together for it to be all it can be. My understanding of networking is probably far below that of yours, but I did get my Rovio to work using some alternate settings. This is what I have and it works great. So maybe try this checklist and see if you can get it going:
-Make sure your Rovio is running the latest firmware v 5.03.
-Reset your Rovio to factory default using power switch cycling (see forum if you don't know how to do that)

-As you go through the setup process, don't use the option to assign a static IP address to Rovio. Let your router's DHCP server do this.
-Don't enter any settings in for dynaminc DNS or anything like that for now.
-Once you have completed setup, you should be able to control Rovio on your internal network. Simply typing it's internal IP should bring up it's page in IE.
-As for port forwarding, I used some different settings. Create a port forwarding rule forwarding external port 9000 to internal port 80 for Rovio's IP address. Then create another port forwarding rule that directs traffic from external port 9001 to internal port 554 at Rovio's IP address.
-At this point, if everything is working, then now you should be able to type into your browser xx.xxx.xx.xxx:9000 where the x'es are your external IP. If successful you will see Rovio's page the same as if you typed 192.xxx.x.xxx:80

-Note that you will see a message on Rovio's page with a red exclamation mark and a popup that says"failed to connect to portal". Ignore this. Rovio is still online.
-If you like the convenience of using a domain with Rovio, then you should still leave the DNS page blank. Just include the external port that you are forwarding to Rovio's port 80 in the address sytax. For me, I type http://mydlinkdomain.dlinkddns.com:9000 and I access my Rovio. Or, I could type 72.xxx.xx.xxx:9000 and get the same result using my external IP. I never could get the dns page to work on Rovio so I just do it this way.

That's my setup. Hope it isn't clear as mud now but sometimes its best to just start from scratch, wipe out all your old settings, and try something new. If you get Rovio working and have a good internet connection with good upload speeds (30Mbps down, 4 Mbps up here) get ready to have a blast chasing your pets and family around the house from work. Good luck!

ZekeGraal
ZekeGraal's picture

I will try this as soon as I get time, (exams this week), then I'll report here :]

cowboyctx
cowboyctx's picture

Also your default gateway should be 192.168.1.1 the 10.1 you have it seto now does not exist on your network.