Robosapien V2 help..

4 posts / 0 new
Last post
morrongafish
morrongafish's picture
Robosapien V2 help..

Hello,

2 weeks ago I bought, not knowing what I was getting myself into, a Robosapien v2 at a yard sale. I bought it for my 6 yr old son cuz I thought it was really cool. I asked the lady if it worked she did not know. So I offered her 10 dollars and off I went with this big red robot that my son was going to use as an "enemy of the earth where his little action figures would be able to destroy it".

Very little did I know what I have bought. After cleaning the rusty battery terminals, the thing worked! but only for about 20 min. Just as I read on other threads here, robot bent backwords, said batteries low and stopped working after 10 min. Went and bought new batteries, installed them and pop goes the AA batteries. Sure enough took legs apart and wire confetti all over the place. Here comes where I need help.

I rewired the bad wires. The robot still will not turn on. Yes, new batteries, I checked with my multimeter and the cables that come out of the legs have power at the plugs that are attached to the circuit board. Since you guys are way more experienced at this than I am, I am hoping someone can just point me to the direction of where the problem might be. This is for my son and he has been waiting patiently for 2 weeks to play with this thing. PLEASE HELP.....

 

Thanks in advance for the help!

Roger

nomad
nomad's picture

hi roger.you did the first part.now the second.2 most problems after rewiring,
are the mean circuitboard or on/off swith.for that you need second v2.
or some time you find special stores who restore circuitboards.
see home page choose forum jump and then v1/v2 there you find answers.good luck

morrongafish
morrongafish's picture

Thank you Nomad. I checked the on/off swith with the multi meter. I am seeing the meter with voltage when I turn on the switch and no voltage when I shut off the switch. Unless I am doing it wrong, seems like the culprit here is the main circuit board. After researching more on this robot, looks like it will be one in a million to find it again for $10.00 dollars.

nomad
nomad's picture

hi ,yes you need second hand v2 to fix one robot.i did also test on on/off swith
desame whit voltmeter .but thats not security if its a good one.i replace all,
mean board,and swiths before he worked.but you need always parts for v2,
if your son wants it for longer time.so try to find second one.good luck