stuck in bootstap mode, any ideas

2 posts / 0 new
Last post
crazygeorge
crazygeorge's picture
stuck in bootstap mode, any ideas

Hi

 

I have an RS v1  stook in bootstrapmode.  I have removed all connections and checked the board.   

 

I can boot into it with nocturnals and helibots files/instructions  and get option toi reflash bootloader, and it all seem to work,  but my board is stuck in BS mode.

I may have messed up the size of the nand flash partition, ( left card in with proper 2v upgrade not v1-v2 ) but 

 

1.  Am not sure if that would affect it

2.  i think i can only correct it if i get the right bootloader on it.  

 

any suggestions anyone,  

Helibot
Helibot's picture

Hi CrazyGeorge,
I will see if I can help ...although its been awhile since I used the bootstrapping!!

>but i could not seem to get the re-flash bootloader to stick
What do you mean? Could you successfully flash a new bootloader (with no errors shown)?

The board should not get stuck in bootstrap mode, if you take the grounding of j15 off , it should go back to normal booting mode. maybe check there are no solder bridges. Maybe try adding a pull up resistor instead of letting it float?

>I may have messed up the size of the nand flash partition,
>( left card in with proper 2v upgrade not v1-v2 ) but
If your NAND flash size is wrong then this shouldn't leave you board in BS mode, it should try to boot (and most likely get errors or lockup immediately at start of boot, I am not sure what you will get in the console.)

I think Freddy has successfully done a Bootstrap on a RSMV2 board. He maybe able to help with 2 pad or 4 pad question? (I have only got bots with RSM V1 boards).

Cheers
Helibot