Rovio

Fimware with Brightness fix (somehow..)

chris75's picture
Forums: 

I've done a quick patch to rovio code (rovio.js) to allow brighter images.

Works on my Rovio and is usefull in low light conditions.

Based on Gandalf findings that poking via i2c the brightness register in camera allow better control.

I've submitted the patch and uploaded recompiled firmware (Rovio-chris75-503c.bin) on sourceforge:

Using the Rovio as the controller of a larger robot

Schlauncha's picture
Forums: 

I always thought the Rovio was neat, and recently I picked one up and have been playing with it, and sharing it with people on another forum I'm active on.  One limitation is that it cannot really drive outside other than on flat hard surfaces, so driving around the lawn isn't going to work.

 

Well, I set out to change that.  I can build other robot bases, and decided to see if I could hook an Arduino up to the Rovio, to "listen" to what the three motors were doing, and translate that into an output from the Arduino that can run servos or ESC's for larger motors.

 

Connection issue

Xraybroadcaster's picture
Forums: 

Greetings, roboteers! I recently acquired a "new" Rovio and can't get it going. (Ebay trickery- poor rovio is dusty, the dock looks like it had been out for years)I would, however, like to see it in action before I return it.  Any help will be greatly appreciated! -power seems fine- batteries charge, and power indicator is constant green.-WIFI signal broadcasts stable and strong- picked up by both PC and Iphone 5.-I have done a hard reset- led blinked red-orange-green to confirm.-I've removed the battery for 5 minutes, just to make sure any RAM is cleared too.-the USB connection cable is mi

Connection issue

Xraybroadcaster's picture
Forums: 

Greetings, roboteers! I recently acquired a "new" Rovio and can't get it going. (Ebay trickery- poor rovio is dusty, the dock looks like it had been out for years)I would, however, like to see it in action before I return it.  Any help will be greatly appreciated! -power seems fine- batteries charge, and power indicator is constant green.-WIFI signal broadcasts stable and strong- picked up by both PC and Iphone 5.-I have done a hard reset- led blinked red-orange-green to confirm.-I've removed the battery for 5 minutes, just to make sure any RAM is cleared too.-the USB connection cable is mi

Connection issue

Xraybroadcaster's picture
Forums: 

Greetings, roboteers! I recently acquired a "new" Rovio and can't get it going. (Ebay trickery- poor rovio is dusty, the dock looks like it had been out for years)I would, however, like to see it in action before I return it.  Any help will be greatly appreciated! -power seems fine- batteries charge, and power indicator is constant green.-WIFI signal broadcasts stable and strong- picked up by both PC and Iphone 5.-I have done a hard reset- led blinked red-orange-green to confirm.-I've removed the battery for 5 minutes, just to make sure any RAM is cleared too.-the USB connection cable is mi

Pages